Login Register Donate

Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
>>>>>UnifL RC testing 16.2.1 < 15.xxx /16.xxx<<<<<<
#1
Bug 
Thanks to the testing Darch has done on our certificate and thanks to User1 for finding newer drivers/ last drivers in general relating to non-CGN - newer than 16.2.1 (and Darch for doing some preliminary tests)

We need people to test, play around, report on these drivers so we can pick a candidate for modding:

Here is an overview of the current drivers that are newer than 16.2.1 for non-GCN devices: https://docs.google.com/spreadsheets/d/1...sp=sharing

You can edit this document with your findings!

There are 2 main candidates:

  • 15.301.2601.1002 FirePro driver:
Quote:These appear to be the latest FirePro set on AMD's site along with a newer beta (16.30) that you explained wont install, or at least i couldn't get it to. Wonder if it's just a few dll's as it appears to get 95% there on my blackcomb/barts. 

If anyone wants a pre-mod to do further tests, I recently added the non-gcn to the inf you can download below.
I had this already prepared but since 16.101 was close enough, I never uploaded it, but here they are...

AMD Radeon Software Crimson 15.301.2601.1002 (w/non-gcn inf mod) Download (Win10 only - use at your own risk!)

Notes:

* Must be installed via devmgr w/driver sig disabled, than you can run AMD installer
* Diff branch than 16.101, but only 7 days older in creation date
* The size is 377mb since it contains everything up to AMD's cleanuninstall utility incl. Cnext / Radeon Settings "Crimson" Edition
* It should support all cards (same as official) on Win10 only 
* Untouched inf's remain for other os's, will post in a future revision after extensive testing
* Reports that OpenCL isn't working for some, but works for me
http://forums.guru3d.com/showpost.php?p=...stcount=33

  • 16.101.2901.1001 driver:
Quote:Created Mixed package for non-gcn, should contain all ids from 16.2.1

Must be installed with diver signature enforcement disabled install as you would any other 
crimson otherwise,
includes:
-16.7.3 radeon settings,
-16.101.2901.1001 with old ocl libs,
-newer Hdmi driver(installs fine no idea if it actually works)
-Secondary inf in driver folder if you have mixed gcn(503/502)/non-gcn laptop graphics (don't know if works)
-added wrestler/sumo to inf (30/07/2016) 
broken:
video settings tab is blank due to old va libs,
but has Opencl working so idc.

released AS-IS, if it breaks something, I am not responsible.

https://www.sendspace.com/file/htlaff

http://forums.guru3d.com/showthread.php?t=409002


You are likely to experience issues with OpenGl / CL and we need as much information on this as possible in your reports.

You can obtain working OpenCL via:

Quote:[*]Restart your system into safemode
[*]Copy the dlls(from a driver that has working OpenCL - Check the google Table for links - advise: [b][i]15.201.2601.100515.201.2901.1004 FirePro - 15.301.2601.1002 FirePro  [/i]) [/b]

[*]from the driver to system32 and syswow64 (problems with copy? try safe mode!)
[*]System32: 
amdocl12cl64.dll
amdocl64.dll
atiumd6a.dll
clinfo.exe
amd_opencl64.dll rename to OpenCL.dll


[*]Syswow64: 
amdocl.dll
amdocl12cl.dll
atiumdva.dll

amd_opencl32.dll rename to OpenCL.dll
[*][b]Restart your system[/b]
[*]

To test OpenCL please run LuxMark, CompuBench or GPU-z



Quote:15.201.2601.1005 http://download.windowsupdate.com/d/...0c6588b842.cab (or just the OpenCL libs) since these are probably the last true drivers to support non gcn cards 100%.

-user1


[*]



Notes:

  • Cnext elements are broken for legacy cards and even if they're installed, not working at all like shader cache. -Please test this and report.


  • If Cnext won't install then install it from another release! (either Cnext or CCC) - Latest CCC version is available in UnifL 16.2.1


  • 15.301.2601.1002  - Steam fullscreen playback is working with this driver. Please confirm if it works for the other driver too.

[*]
Some observations by Darch:



  • So far so good. In Overwatch, i am getting >40fps all the time. With 16.2.1 or older drivers, i was getting 30 fps with action scenes and 30-45 in general. In Cities: Skylines with 100.000 population, game holds at >24 fps which is a very good with all of particle effects. With 16.2.1 game turns into the slide show in that situation.
  • This "15.301.2601.1002 with 15.11.1 CCC and 15.11.1 Opencl libs" setup is very good. Dont know about kernel date but it's an improvement over 16.2.1.
  • Yes, installed firepro from device manager. After that, installed 15.11.1 Catalyst Control Center(not cnext) and replaced dll's with 15.11.1 Opencl libs.
  • Also used Dx9 tweak from radeonmod and downclock fix for non-gcn.(http://forums.guru3d.com/showthread.php?t=406157)

  • Bonebird confirmed the downclock fix to have improved his WOW performance - stability on DX9 - We need more reports 
  • Firepro driver is having latency issues. When fps dropped below 60, it started to act weird. 16.101.2901.1001 doesnt have this issue.
  • Tested 16.101.2901.1001 and Firepro drivers side by side yesterday. While having some issues with Steam(loadlibrary error when fullscreen video playback) 16.101.2901.1001 is better than Firepro by 1-2 fps.
[*]



Make sure to use DDU! this is trivial as residual values will mess up your performance.

Final remarks: Testing is not easy. Thankfully this project has seen a lot of people that have committed tremendous time and interest. Darch is one of these people. The goal is to find the optimal driver, Apply the most optimal fixes and then prep it for a proper packed release.
[Image: btn_donate_SM.gif] Private support
Reply
#2
Since i have vanilla "16.101.2901.1001" version, downloading "16.101.2901.1001 with 16.7.3 radeon settings" package right now.

Also there's a new Intel Hd 3000 driver too, if anyone missed that;

http://www.mediafire.com/download/9ndy2w...0.4459.cab

Here you go.
Reply
#3
(08-29-2016, 08:23 PM)ZAP Wrote: Works good for hd7670m, thanks Smile

Sorry ZA but we need much more detail than that. Please elaborate. We want to release the best version possible for you guys.

16.xxx holds major performance improvements. We will also be able to insert performance game profiles from the newest drivers into these once we release.
[Image: btn_donate_SM.gif] Private support
Reply
#4
Can we mod 16.101.2901.1001 for Windows 7?

I am back to Windows 7 for testing deeply(Windows 10 performance issues with old pc's) but can't figure out this one. Changing inf doesn't seems to work. Device manager gaves "missing files" error when tried to install it.

16.101.2901.1001 dll's(aticfx32, aticfx64, atidxx32, atidxx64) works good in Windows 7 btw.
Reply
#5
(08-30-2016, 05:45 PM)Darch Wrote: Can we mod 16.101.2901.1001 for Windows 7?

I am back to Windows 7 for testing deeply(Windows 10 performance issues with old pc's) but can't figure out this one. Changing inf doesn't seems to work. Device manager gaves "missing files" error when tried to install it.

16.101.2901.1001 dll's(aticfx32, aticfx64, atidxx32, atidxx64) works good in Windows 7 btw.

Unfortunately not before we get more tester info.

You can just change the header in the inf file. Do a quick compare job between W7 and W0 and you will see that it is pretty straight forward.

What kind of performance issues did you have with Windows 10 AU?

I have a rough feeling that I might know what you are talking about .. if it is HDD related. .. freezing and such.
[Image: btn_donate_SM.gif] Private support
Reply
#6
Changing the header in Windows 10's inf works, thanks. I tried to modifiy Windows 7 inf but this one so simple Smile

Can't figure out Windows 10 vs Windows 7 differences fully yet but there's something with cpu and hdd usage. Different cpu timings maybe? Same games performs better in Windows 7 with Sandy Bridge.
Reply
#7
(08-31-2016, 12:56 AM)Darch Wrote: Changing the header in Windows 10's inf works, thanks. I tried to modifiy Windows 7 inf but this one so simple Smile

Can't figure out Windows 10 vs Windows 7 differences fully yet but there's something with cpu and hdd usage. Different cpu timings maybe? Same games performs better in Windows 7 with Sandy Bridge.

Its a bug with the MS Storage Spaces Controller in windows 10 AU.

You need to install Intel Chipset SATA Raid Controller 14.10.0.1016
[Image: btn_donate_SM.gif] Private support
Reply
#8
My pc only supports Intel Chipset SATA 12 and older versions.

Anyways, 16.101.2901.1001 performs much better in Windows 7.

- Steam bug is gone in Windows 7(This problem occurs only in Windows 10)
- Same games(Overwatch, WoW, Rome 2 Total War, Batman Arkham Origins) performs better, 3-5 fps more in general.
- Crimson Power Savings is not relevant for non-gcn cards. Even with max power savings, your non-gcn card should performs same with older drivers.
- I blamed Crimson before but it seems our problem is Windows AU(or Windows 10).
- In windows 7, max cpu temperatures are lower than Windows 10. This is not a "Windows 10 uses cpu's more efficiently than older versions" situation, Windows 7 beats it in general performance. From chipset perspective; Something is broken with Sandy bridge in Windows 10.
Reply
#9
(08-31-2016, 09:51 AM)Darch Wrote: My pc only supports Intel Chipset SATA 12 and older versions.

- I blamed Crimson before but it seems our problem is Windows AU(or Windows 10).
- In windows 7, max cpu temperatures are lower than Windows 10. This is not a "Windows 10 uses cpu's more efficiently than older versions" situation, Windows 7 beats it in general performance. From chipset perspective; Something is broken with Sandy bridge in Windows 10.


No. This is a known bug on Windows 10 AU if you follow the news.

You had to update your Intel RAID drivers to remove the stuttering .. freezing bug.

The newest SandyBridge driver for the RAID controller will work:

http://www.station-drivers.com/
[Image: btn_donate_SM.gif] Private support
Reply
#10
Well, i can't update any driver newer than version 12.
Reply
#11
"Well, i can't update any driver newer than version 12."

Check your HWIDs and compare. You might be surprised.

On my sandybridge I can upgrade to this:

Intel Rapid Storage Technology (RST) Version 15.0.2.1044 WHQL

http://www.station-drivers.com/index.php...57&lang=fr
[Image: btn_donate_SM.gif] Private support
Reply
#12
Alright so I've just tested this:
Quote: Wrote:Also used Dx9 tweak from radeonmod and downclock fix for non-gcn.(http://forums.guru3d.com/showthread.php?t=406157)
^^ could be placebo .. please test.

So Diablo 3 RoS is notorious for performing like garbage on switchable graphics post 14.4 (being DX9 game and whatnot).
Applied the dwords from the guru3d thread plus the DX9 tweak, that you guys bundle with UnifL, and literally made the game from unplayable in certain cirumstances to smooth as butter. Even though the frames are the same, the massive slowdowns in huge fights and the freezes are completely GONE for me. I've tested it in the same area with the same monster density - the screen is filled with crap, without the dwords - unplayable, with the dwords smooth as butter.  Big Grin


I don't what exactly this "non-gcn downclocking fix" did (Clockblocker did nothing for me in the past), but it made a HUGE difference. Thanks to whoever found this!  Cool
Reply
#13
(08-31-2016, 12:31 PM)Bonebird Wrote: Alright so I've just tested this:
Quote: Wrote:Also used Dx9 tweak from radeonmod and downclock fix for non-gcn.(http://forums.guru3d.com/showthread.php?t=406157)
^^ could be placebo .. please test.

So Diablo 3 RoS is notorious for performing like garbage on switchable graphics post 14.4 (being DX9 game and whatnot).
Applied the dwords from the guru3d thread plus the DX9 tweak, that you guys bundle with UnifL, and literally made the game from unplayable in certain cirumstances to smooth as butter. Even though the frames are the same, the massive slowdowns in huge fights and the freezes are completely GONE for me. I've tested it in the same area with the same monster density - the screen is filled with crap, without the dwords - unplayable, with the dwords smooth as butter.  Big Grin


I don't what exactly this "non-gcn downclocking fix" did (Clockblocker did nothing for me in the past), but it made a HUGE difference. Thanks to whoever found this!  Cool

[Image: 65649722.jpg]

You will have to thank Darch for finding it! 

Are any other games affected or would you say that it is just DX9?
[Image: btn_donate_SM.gif] Private support
Reply
#14
"PCI\VEN_8086&DEV_1C03&SUBSYS_1657103C&REV_04"

Here's my device info.

Tried all of these drivers but none of them worked. Do you use Ahci or Raid mode? Raid mode is supported but ahci is not.
Reply
#15
(08-31-2016, 11:57 AM)Darch Wrote: Well, i can't update any driver newer than version 12.

(08-31-2016, 01:09 PM)Darch Wrote: "PCI\VEN_8086&DEV_1C03&SUBSYS_1657103C&REV_04"

Here's my device info.

Tried all of these drivers but none of them worked. Do you use Ahci or Raid mode? Raid mode is supported but ahci is not.

that might be the issue.

Indeed I am on Raid0 by factory default. .. in which case I do not know what the solution for this is.

I suppose changing to Raid is no option. I am also not sure if MS has releases a fix yet for Win 10 AU with devices facing this issue.

It was an assumption by many that it was some RAID configs that were affected.

Could it be something else?

Maybe an Insider Preview build?
[Image: btn_donate_SM.gif] Private support
Reply
#16
I'd say it's just DX9, when I played MGSV for instance (DX11 and somewhat demanding for higher settings) I had no problems running at almost constant 30 fps, without the huge slowdowns and freezes like in D3. Most of my other DX9 titles are pretty old, and will run even on my 1st gen igpu no matter what, so I can't confirm for sure. Smile

Which reminds of something else that is on topic - GPU-Z shows me that I don't have the OpenCL libraries, but OpenGL works fine like in Homeworld Remastered.
I don't know if OpenCL and GL should be connected in some way or it is possible to have this situation... this in on UnifL 16.2.1.

PS Thanks Darch for finding this fix! Big Grin
Reply
#17
(08-31-2016, 01:35 PM)Bonebird Wrote: I'd say it's just DX9, when I played MGSV for instance (DX11 and somewhat demanding for higher settings) I had no problems running at almost constant 30 fps, without the huge slowdowns and freezes like in D3. Most of my other DX9 titles are pretty old, and will run even on my 1st gen igpu no matter what, so I can't confirm for sure. Smile

Which reminds of something else that is on topic - GPU-Z shows me that I don't have the OpenCL libraries, but OpenGL works fine like in Homeworld Remastered.
I don't know if OpenCL and GL should be connected in some way or it is possible to have this situation... this in on UnifL 16.2.1.

PS Thanks Darch for finding this fix! Big Grin

Good good. 
Now we just need 2 more people to confirm this fix for DX9 games.

Try opening Steam in Big Picture mode to see what will happen

For OpenCL please do the following:

Follow these steps:


[*]Restart your system into safemode
[*]Copy the dlls(from 15.201.2601.1005 latest non GCN driver with working OpenCL x64

[*]from the driver to system32 and syswow64 (problems with copy? try safe mode!)
[*]System32: 
amdocl12cl64.dll
amdocl64.dll
atiumd6a.dll
clinfo.exe
amd_opencl64.dll rename to OpenCL.dll


[*]Syswow64: 
amdocl.dll
amdocl12cl.dll
atiumdva.dll

amd_opencl32.dll rename to OpenCL.dll
[*][b]Restart your system[/b]


to test OpenCL please run LuxMark, CompuBench or GPU-z


Darch: Please correct me if I am wrong.
[Image: btn_donate_SM.gif] Private support
Reply
#18
Hi everybody. There 2 screenshots after installation dlls from 15.201.2601.1005 latest non GCN driver with working OpenCL 64x on last catalyst 16.2.1 UnifL. After change dlls, pc won't start, but after poweroff, and turn pc again Windows start fine and look, gpu-z detect opencl and Steam Big Picture work fine (I not use BP and think he work fine for me all time, Legacy and UnifL).
I look forward to when you release a new driver assembly.
My laptop is HP Pavilion G6 2319sr with other cpu AMD A10 5750m, apu Radeon HD 8650g, gpu Radeon 7670m. 8Gb ram, Windows 10 Home 64x.
[Image: 5cc0055ee55523898b1057759397fc23.jpg][Image: cf2246e0b3cb317ddc29d65a9c145d3a.jpg]
Update. After installing the dll OpenCL files noticed a decrease in games FPS. I tried to play Saints Row IV, Mass Effect 2, games work worst with OpenCL, worst than legacy drivers. In MSI Afterburner GPU Crossfire load max on 20-30%.
Thanks a lot.
Testing in: 
- Crysis Demo 64x DX9 1366x768, full settings, without vsync
- Battlefield 2 Demo DX9, 1366x768, full settings, without vsync
- Serious Sam 2 Demo DX9, 1366x768, full settings, without vsync
- The Chronicle of Riddick: Escape from Butcher Bay Demo (AMD 64x) OpenGL, 1366x768, full settings, without vsync
- STALKER: Call of Pripyat benchmark DX9, full advanced light, max. settings, SSAO Default-low quality, without vsync
- Resident Evil 5 benchmark DX9. 1280x720, full settings, AA 8x, without vsync


Reply
#19
(09-01-2016, 08:26 AM)mp3downloader Wrote: Hi everybody. There 2 screenshots after installation dlls from 15.201.2601.1005 latest non GCN driver with working OpenCL 64x on last catalyst 16.2.1 UnifL. After change dlls, pc won't start, but after poweroff, and turn pc again Windows start fine and look, gpu-z detect opencl and Steam Big Picture work fine (I not use BP and think he work fine for me all time, Legacy and UnifL).
I look forward to when you release a new driver assembly.

My laptop is HP Pavilion G6 2319sr with other cpu AMD A10 5750m, apu Radeon HD 8650g, gpu Radeon 7670m. 8Gb ram, Windows 10 Home 64x.
Update. After installing the dll OpenCL files noticed a decrease in games FPS. I tried to play Saints Row IV, Mass Effect 2, games work worst with OpenCL, worst than legacy drivers. In MSI Afterburner GPU Crossfire load max on 20-30%.
Thanks a lot.

Thank you for the report!

Can you revert back to the old 16.2.1 to confirm that the speed improves?

You could also try the 16.101.2901.1001 driver.

EDIT: I am not sure if your results will correlate to users with Intel + AMD cards since you are on a PXAA (AMD + AMD) setup.

We will need someone to check OpenCL and performance for PXAI (AMD + Intel)
Note - Please disregard performance results for PXAI
[Image: btn_donate_SM.gif] Private support
Reply
#20
(08-31-2016, 01:09 PM)Darch Wrote: "PCI\VEN_8086&DEV_1C03&SUBSYS_1657103C&REV_04"

Here's my device info.

Tried all of these drivers but none of them worked. Do you use Ahci or Raid mode? Raid mode is supported but ahci is not.

http://www.neowin.net/news/microsoft-has...ary-update

check this out please.
[Image: btn_donate_SM.gif] Private support
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)